All about the software

Re: MiniTiouner will not start.

Postby EA3FNT » Thu 27 Aug 2020 06:01

Can somebody please help?


I have entered username and password in the .ini file just in case it was required to run this software. It did not help either.
I attach screenshot of test my MiniTiouner.
This is what Test My Minitiouner says:

-------------------------

DLL version: 3.2.14
we have found 2 device(s)
............................................
device 0:
device serial N° DA3HOL6RA
device named: USB <-> NIM tuner A
For I2C, we can use this device
FT2232H NIM_I2C is open
OK, we will use it with Handle: 9499800
............................................
device 1:
device serial N° DA3HOL6RB
device named: USB <-> NIM tuner B
For TS, we can use this device
FT2232H FIFO open for TS2
OK, we will use it with Handle: 9499240
............................................
USB driver version: 2.12.28
>>>>>>>>>> NO MiniTiouner-Pro connected to USB AUX! <<<<<<<<<<<
==============================================================
****************** NIM I2C controler INIT *******************
NIM_I2C controler INIT OK
OK MPSSE is empty
Init MPSSE NIM I2C done!
**************************************************************
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
NIM Test
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
I2C repeater OFF
Reset Demod
Trying to get the Demodulator serial number
Demodulator Address = $D2
we get the value = 81
Demodulator is a STV0910A
NIM is a SERIT_FTS4335/FTS4334L
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
MiniTiouner with NIM Serit FTS-433x detected
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
--------------------------------------------------------------
Repeater mode OFF
writing a value at address X seems OK
trying to read 1000 times register X
time to do it : 547msec
we have : 0 reading errors from 1000
test: 512 writing/reading the Demodulator
we have : 0 writing errors and 0 reading errors from 512
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
STV0910 Demodulator setup
--------------------------------------------------------------
Writing demodulator default values ==> OK
time to do it: 781msec
STV0910 Init done
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
------ LNA booster detection ------
LNA found by reading the value : 33
2nd LNA found by reading the value: 33
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
writing $5A at address X seems OK
we try to do 1000 readings of register X after demodulator init
time to do it : 766msec
we have : 0 reading errors from 1000
test: 512 writing/reading the Demodulator after initialization
we have : 0 writing errors and 0 reading errors from 512
**************************************************************

xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Init Serit FTS-4335/34 ZeroTuner
--------------------------------------------------------------
ZeroTuner initialization ==> OK
Reading values in STV6120 registers
Reading STV6120 is OK
Demodulator Address = $D2
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
END Test NIM
$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$$
.........................................

TS1 led is ON
TS2 led is ON
Attachments
TestMinitiouner.jpg
Screenshot
TestMinitiouner.jpg (336.28 KiB) Viewed 833 times
EA3FNT
 
Posts: 6
Joined: 12 Aug 2020

Re: MiniTiouner will not start.

Postby F6DZP » Thu 27 Aug 2020 21:22

I don't understand your question.
This test show you that your MiniTiouner seems good and starts normally.

have you also tested the driver installation with "CheckMiniTiouneDriverAndFilters" ?

and after
run Minitioune ?

Jean-Pierre F6DZP
F6DZP
 
Posts: 1065
Joined: 24 Dec 2010

Re: MiniTiouner will not start.

Postby EA3FNT » Sun 30 Aug 2020 08:18

The question is "Why Minitioune, last stable version, installed in a brand new machine following all the steps written in the instructions, does not go beyond the first -white- screen?"

Yes, Minitiouner starts normally. But Minitioune does not work.

If I run the "CheckMiniTiouneDriverAndFilters" BEFORE running Minitioune, there are no errors. In the end of the message I include the text of the checkings.

But, if I run the check WHILE MiniTioune is showing the white initialization screen, when I press the "USB Tuner" button the following error appears:

"FT2232H has bad device B parameters. use FTprog to reprogram it"

I attach a screenshot of the check response (The USB port must be busy).


If I kill the MiniTioune program with the Task Manager and I check Drivers and filters again, the check works as before, with no errors:


xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
DLL detection
----------------------------------------------------------------------
DLL version: 3.2.14
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
USB channels detection
----------------------------------------------------------------------
we have found 2 device(s)
............................................
device 0:
device named: USB <-> NIM tuner A
For I2C, we will use this device
Handle: 160644144
............................................
device 1:
device named: USB <-> NIM tuner B
For TS, we will use this device
Handle: 160644296
............................................
USB driver version: 2.12.28
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
I2C initialisation
----------------------------------------------------------------------
I2C controler INIT OK
OK MPSSE is empty
Init MPSSE I2C done!
***********************************************************
------ NIM and Demodulator detection ------
STV0910 Identification correct : chip_ident($5), release($1).
writing test OK:255
SeritPro NIM detected
initializing STV0910
STV0910 init OK
xxxxxxxxxxxxxxxxxxxxx
------ Synthesizer detection ------
Synthesizer found, value: $77
STV6120 init OK
------ LNA booster detection ------
LNA found by reading in register0 the value : 33
2nd LNA found by reading in register0 the value: 33
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
------ Audio output detection ------
2 Sound output(s) found
product name :Speakers (USB Audio)
product name :Speaker (Realtek(R) Audio)
Stereo
left volume = 32767 , right volume = 32767
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
------ Search for Directshow filters and codecs ------
Filter graph creation success.
OK :"Universal Source" filter found.
OK : "Universal Source" filter added.
OK :"MPEG-2 Demultiplexer" filter added.
OK :"LAV splitter Source" filter found.
OK :"LAV splitter Source" filter added.
OK :"LAV video decoder" filter found.
OK :"LAV audio decoder" filter found.
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
------ IP and UDP detection ------
IP n° 1 = 10.6.2.51
IP n° 2 = 192.168.1.31
UDP address : 230.0.0.1 port : 1234 using IP interface : 10.6.2.51
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
------ testing XML to Web ------
XML to Web OK
--

I2C Initialisation
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
-------------------------------------------------------------------------------------------------

ONLY ONCE, after stopping MiniTioune with the Windows Task Manager, an I2C controller initialization appeared and the check gave:"

ERROR_MPSSE should be empty
Init MPSSE done!
"
But when i tried again with the MiniTioune stopped, the checks were OK again.

I attach screenshots.

Thanks.
Attachments
I2C_INIT.jpg
This appeared only once when I stopped MiniTiouner with Task Manager
I2C_INIT.jpg (11.98 KiB) Viewed 806 times
WHILE_RUNNING.jpg
This is what appears when I run CheckMiniTiouneDriverandFilters while MiniTioune is trying to start.
WHILE_RUNNING.jpg (244.46 KiB) Viewed 806 times
EA3FNT
 
Posts: 6
Joined: 12 Aug 2020

Re: MiniTiouner will not start.

Postby F6DZP » Sun 30 Aug 2020 21:09

I don't understand and cannot answer.
One thing is sure : you cannot run 2 software that use the same MiniTiouner at same time.
so it is normal that if Minitioune is running, checkMibitioune driversAndfilters cannot access to the MiniTiouner.

If
1)TestMyMiniTiouner gives all result good
2)Check MinitiouneDriversandFilters shows all leds green
3) and Minitioune "does not go beyond the first -white- screen"

There is something wrong with your computer or Windows installation. or MiniTiouner or ????

About Minitioune and MiniTiouner, there is one thing I have not already put in my test: to be sure that you graphic card driver is not the windows generic basic graphic driver, but really the driver specific to your card. This is the only cause I can remember that could cause a new problem that I have not tested in the Check software "

so, if your new windows installation is well done = you have the good graphic driver (AMD or NVidia or ..) and have these trebbles, I cannot say why.

if you have not found the solution , to go further :
A) have you tested your MiniTiouner on another PC or a friend's PC that has alreday run Minitioune without problem using another MiniTiouner
B) have you tested another MiniTiouner (from a friend) that is known to be good?


Jean-Pierre F6DZP
F6DZP
 
Posts: 1065
Joined: 24 Dec 2010

Re: MiniTiouner will not start.

Postby EA3FNT » Wed 2 Sep 2020 19:27

Thank you for your response.

Unfortunately, the software does not start yet in this computer yet :-(
All other software I have tried in this brand new PC works just fine, including SDR Console, and so on.

It was clear that both programs could not access the device at the same time. No surprise there.

Windows 10 Pro 64 bits has been freshly installed from the Microsoft web site and it is the latest release.

1-2-3 are true.

Video graphics card is an Intel UHD. It has the specific driver for this card, with the latest version updated from the HP web site. Computer is a brand new HP notebook model 15s-fq1115ns. The video tests went OK when using this driver, as mentioned.

A) I have tested my MiniTiouner on another PC without this problem. The white window closes and the program starts normally. However, this other computer is very old and its CPU is overloaded.

B) I built this minitiouner during my vacations. I have no friend with another one to test. But this one passed all tests as specified.

There must be a reason to stop the program during the initial check.

Is there no way to know what is the Minitioune software trying to do when the white screen is displayed? This would certainly be a tremendous help.

Thanks once more,

Arnau
EA3FNT
 
Posts: 6
Joined: 12 Aug 2020

Re: MiniTiouner will not start.

Postby EA3FNT » Tue 15 Sep 2020 18:05

Unfortunately, the software doesn't start yet.

Just to add a bit of information, I connected an OLED display to the MiniTiouner V2 and after running the program it shows the following:

----------------------------
Tuner A

Freq: 10491500 KHz
SR: 01500 kS/s

RF level:
MER:
----------------------------

Meaning it doesn't go through the stages to populate RF Level and MER values?

I am completely blind to what is going on. MiniTioune is the only software I haven't been able to run on this computer (as I said, brand new, with all Windows 10 updates, specific drivers, and so on).

I think I read somewhere about somebody removing some file from a MiniTioune directory because the software was attempting to register some dll without success. I haven't been able to find that post again.
EA3FNT
 
Posts: 6
Joined: 12 Aug 2020

Previous
Forum Statistics

Who is online

Users browsing this forum: No registered users and 1 guest

Options

Return to Minitioune