Page 1 of 2

Mintiouner Pro received but ferrite of L12 was broken

PostPosted: Wed 22 May 2019 07:11
by SV2RR
I am particularly sad :cry: because today I received the parcel from REF that contained the Mintiouner Pro, but a piece of ferrite of L12 was broken.
Serit tuner and some other parts were in the same bag with the assembled pcb without any protection. I have not assembled and wire it or test it yet.
I would like to ask if this will cause a malfunction on the receiver or not.
How can find a replacement part?
https://yadi.sk/i/lpg3ILeW8-yd0w
https://yadi.sk/i/hereWDl1dVGI2w

Re: Mintiouner Pro received but ferrite of L12 was broken

PostPosted: Wed 22 May 2019 07:41
by G4WIM
I had the same problem with mine but was able to salvage a part from an old circuit board.

Sadly that was not the end of my trouble as there seems to be a problem with the TS signal not reaching the USB so with JP help I'm investigating this problem as well.

Regards Tim

Re: Mintiouner Pro received but ferrite of L12 was broken

PostPosted: Wed 22 May 2019 08:42
by SV2RR
Thanks Tim for the answer.
So probably is not the only one issue.
Maybe Jean-Pierre F6DZP can help and to advise us how to resolve the issues.

73, Greg

Re: Mintiouner Pro received but ferrite of L12 was broken

PostPosted: Wed 22 May 2019 08:45
by F1TE
SV2RR
Sorry for the inconvenience
Send me your address, I send you a self by post office.
My mail here https://www.f1te.org/

73, Lucien F1TE

Re: Mintiouner Pro received but ferrite of L12 was broken

PostPosted: Wed 22 May 2019 08:58
by G4WIM
Hi Lucien,

hope you don't mind me asking but could you send one to me as well because I'm not sure I have the correct value installed (10 or 100uH) as the markings are ambiguous.

No problem if you can't as I'm not sure about your connection to this project and responsibility etc.

I'm yet to get my TS stream working so there maybe other repairs needed - time will tell.

Seems like the supply process needs a small tweak to avoid problems in shipping - the joys of manufacturing !

Regards Tim G4WIM

Re: Mintiouner Pro received but ferrite of L12 was broken

PostPosted: Wed 22 May 2019 09:40
by SV2RR
Thanks Lucien for the quick response, mail send it to you.
I want to ask you also if there is somewhere any detailed info about the additional wiring JST type connectors (most for future use i think) for a newbie like me on this minitiouner pro project.
Thanks!

Re: Mintiouner Pro received but ferrite of L12 was broken

PostPosted: Wed 22 May 2019 09:52
by F1TE
There are specific tools for crimping the contacts, but I think with a little skill and a small clip, you can crimp the contacts by hand and drag them into the boxes.

Re: Mintiouner Pro received but ferrite of L12 was broken

PostPosted: Wed 22 May 2019 14:09
by G3UEQ
G4WIM wrote:Hi Lucien,

hope you don't mind me asking but could you send one to me as well because I'm not sure I have the correct value installed (10 or 100uH) as the markings are ambiguous.

No problem if you can't as I'm not sure about your connection to this project and responsibility etc.

I'm yet to get my TS stream working so there maybe other repairs needed - time will tell.

Seems like the supply process needs a small tweak to avoid problems in shipping - the joys of manufacturing !

Regards Tim G4WIM


Tim
I have ordered one as well and speaking to someone else on forum they also had broken inductor and bent pins. So I have emailed REF Supplies to see if they can kindly improve packing, at least before mine arrives! Other concern is parts hitting the SMD ICs and damaging their connections.
Regards
Andy G3UEQ

Re: Mintiouner Pro received but ferrite of L12 was broken

PostPosted: Wed 22 May 2019 15:28
by G4WIM
Hi Andy,

I have mine working ok now as far as I can tell - it also had a few bent pins on the headers, nothing serious but indicative of inadequate packaging which likely results in the ferrite inductors getting damaged.

While mine is working ok now I suspect it may have an intermittent somewhere - I'll keep a close eye on it while I await the case and display I've ordered.


73 Tim

Re: Mintiouner Pro received but ferrite of L12 was broken

PostPosted: Wed 22 May 2019 22:31
by 2E0LGZ
My Minitiouner pro v2 arrived yesterday and the OLED connector was bent back and the same ferrite was broken and the piece was in the static bag i have super glued it temp for now until i get a replacement its the one with ‘100’ stamped on the top the minitiouner seems to be working ok though
Gary 2E0LGZ